Services are now fully restored and operating normally. We will continue to monitor the system closely. Thank you for your patience!
Posted Dec 05, 2025 - 00:28 AEDT
Update
We have successfully identified the cause of the connection timeouts (Error 524) affecting the service as an issue with the host machine on our third-party cloud platform. The vendor has begun rolling out a fix, and we are closely monitoring their progress to ensure service stability is restored shortly.
Posted Dec 05, 2025 - 00:15 AEDT
Update
We are continuing to investigate this issue.
Posted Dec 05, 2025 - 00:14 AEDT
Investigating
We're currently experiencing some issues with access to the web applications. The engineering team is investigating.
Posted Dec 04, 2025 - 23:58 AEDT
This incident affected: us.nexl.cloud, au.nexl.cloud, and eu.nexl.cloud & 360.nexl.io.