Import functionality degraded in EU region

Incident Report for NEXL

Resolved

This incident has been resolved. All import functionality has been restored and we are continuing to monitor.
Posted Jun 11, 2026 - 01:44 AEST

Investigating

We are currently investigating an issue affecting imports on eu.nexl.cloud.

Some users may be unable to start or complete imports. Our team is investigating and we will provide an update as soon as more information is available.
Posted Jun 10, 2026 - 19:50 AEST
This incident affected: eu.nexl.cloud & 360.nexl.io.