Issues with contact lists
Incident Report for NEXL
Resolved
Only affected 1 tenant and the issue was resolved.
Posted Apr 20, 2022 - 08:57 AEST
Investigating
Currently, we are experiencing issues with contact lists within My Contacts, All Contacts and contact lists within Projects. It seems they have disappeared. We are investigating the issue.
Posted Apr 20, 2022 - 08:35 AEST
This incident affected: us.nexl.cloud.