Issue loading contact and company lists on EU

Incident Report for NEXL

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 17:23 AEDT

Monitoring

We have identified the issue and deployed fixes. We are monitoring the situation.
Posted Oct 08, 2025 - 08:56 AEDT

Investigating

We are currently experiencing issues with the loading of contact and company lists. This also seems to affect Nexl Engage. We are investigating the issue.
Posted Oct 08, 2025 - 08:17 AEDT
This incident affected: eu.nexl.cloud & 360.nexl.io and Nexl Engage (EMS) EU.