Intermittent connection issue: 520 Error on page
Incident Report for NEXL
Resolved
The incident has resolved itself.
Posted Nov 28, 2023 - 13:02 AEDT
Investigating
We are currently investigating an intermittent issue causing our web application to return a 502 Error page. Please refresh the page which will fix the issue.
Posted Nov 28, 2023 - 10:43 AEDT
This incident affected: us.nexl.cloud, au.nexl.cloud, and eu.nexl.cloud & 360.nexl.io.